HX220/AX1800 mesh router optimal setting for maximum speed

Can anyone help me with the best setting for the Tp-Link HX220/AX1800 mesh router?
I have been with Yayzi for almost a month now and I am not getting anything close to the advertised speeds. I initially complained to the team when I was getting about 520Mbps (wireless) download speed instead of the 900Mbps I was paying for, but now I am getting less than 300Mbps (wired).
I have complained to Yayzi support but they keep saying that they can’t find any issues from their end.
Is there anything I need to do?

How are you testing the speed? Can you post some of your results?

Hi Peter,
Thank you for responding.
I am testing with Speedtest.net and Google’s Internet Speed test and, just now, the wireless test results are:
Google’s Internet Speed test - D = 236.5 and U = 141.8
Speedtest.net - D= 195.63 and U = 163.12

Are you able to try this one while using wired https://eri.proof.ovh.net/

If that looks good but tests on wireless looks bad then that at least narrows it down from a connection problem to a wifi problem.

Hi Peter,
Apologies for the delayed response. I just woke up after a night shift.
I have tried testing on https://eri.proof.ovh.net/, and this what I got:
Download: 170.3mbps (maximum speed after 5 tests)
Upload: 230.0mbps
Google’s Internet Speed Test:
Download: 184.7mbps
Upload: 187.3mbps
Speedtest.net results:
Download: 166.85mbps
Upload: 175.28mbps

I downloaded the Wi-Fi Analyser app on my phone. The diagnostics on report for the 5G band shows:

  • Interference: 90% on Channel 48 (currently connected channel on auto settings) Same 90% interference on other available channels, 36, 40 and 44. The recommended channels, 38, 42, 46 and 50 are not available to me. The other available channels are restricted, channels 52 to 165.
  • Signal strength: -45dBm
  • Connection security: WPA2
  • Internet access: Available
  • Link speed: 866Mbps (between my phone and the router) phone test results are 198Mbps.
    Could the issue be with the unavailable channels?

Was the speedtest you did on the site I liked using wired or wireless? Wireless congestion can definitely cause a big problem but the first step is to rule out any connection issue. Reported link speed on wifi can be (mostly) ignored.

All the speed tests results are from a wired test.

Hmm, yeah in that case it doesn’t seem right if you’re getting multiple tests across multiple times of day all wired with bad speeds. Do you have another computer you can test on wired just to also rule that out? If it’s still bad then you may need to wait for Yayzi to check if there’s anything up.

Thanks for all your help and suggestions.
I have tried on a laptop and desktop,and both give similar results.
Yayzi support are aware but communication has only been via email, which has been quite inadequate, especially as there’s no support on weekends or after 5pm on week days.

No problem! Another way to try contacting them is via WhatsApp, they tend to be more communicative that way. We can also try pinging them here @Yayzi_Team

Thank you, Peter. I didn’t know about the WhatsApp option.

Drop me an email to hello [at] yayzi.co.uk FAO of Liam and I’ll take a look for you :slight_smile: