Not getting full 2.5gb speed

speed test link click me

So I purchased a new 2.5gb ethernet card and installed it now my problem is that im only getting 1gb download down still even though I should be getting close to 2.5gb. see attached image upload speed is fine getting 2.3gb upload

Can @Yayzi_Team look into this as I’m obviously not getting full download speeds


The odd thing about that is you’re clearly on a 2.5 profile from the upload, that would make me wonder what would happen if you use a different speedtest server.

I have tried multiple servers which all give the same result. It must be on yayzi end. I have tried different ethernet cables etc and nothing works

@Yayzi_Team @Yayzi_Liam can this be looked into as I’m still in cooling off period as. If can’t get the speeds I’m promised then will be leaving.

Hi Shuan,

I’m running speedtests directly to your router, and we’re getting 2.05Gbps download, can you run some more tests for me?


Just tried the Coventry server and I get slow download speeds, swapping over to 20i in Nottingham gives much closer to line speeds down, but slower upload speeds. This is the joy of peering/routing and not knowing the server load on the remote side. Just because it responds to a ping quickly doesn’t mean it’s the most suitable test server for you. In an ideal world Yayzi would have an on network speedtest server we could use, but I appreciate other things take priority.

A Yayzi speedtest server is in progress :smiley:

1 Like

If you wanted to give me 2.5gb I could be a beta tester for you :laughing:

1 Like

Yes no problem. I have just done three more tests and all don’t go above 1.2gig. See pictures attached

1 Like

Just a thought, have you tried finding the latest drivers for your NIC and installing them to see if it makes any difference?

Hello Craig,

Yes I installed the up to date network drivers for this yesterday. Would you recommend trying to change the NIC to other pci slot?

1 Like

Hi Avalon,

I have just tried 20i Nottingham and gives slower speeds then others

What NIC did you buy? My normal suggestion is Intel, but the i225 was horrible till rev c. and i226 is still pretty new. Realtek have been not awful for 2.5Gb as long as you stick to non jumbo frames.

Another thing to double check as I’m sure it was on here that a saw someone had changed the VLAN priority and it gave them slower speeds.

Make sure VLAN priority is on 0 in your router settings then click ok at the bottom to save.

Try the latest driver: Realtek PCIe FE / GBE / 2.5G / 5G Ethernet Family Controller Software - REALTEK

Also run the speedtest from the router UI if it has the option, what does it get?

yes its 0

1 Like

yes I have installed the latest drivers etc and makes no difference.

Shaun, done some more tests and we’re still seeing 2Gbps+ direct to your router, I don’t believe this to be an issue on the network here - can you just try a few different test servers for me, any around London and just post the results please :slight_smile: