USB-C/USB 3.0 to 2.5G ethernet adapter using RTL8156B chipset

There are many 2.5G Network Interface Cards and adapters that commonly use the same RealTek chipset: RTL8156B

Since joining Yayzi I’ve been having issues (particularly for upload) with drops/loss on the 2Gig Pro+ connection.
The suspicion is being put on the USB-C/USB 3.0 adapters that I am using rather than any fault in the WAN.

So an an experiment I ran up an iperf3 server on a RPi with 2.5G link.
From a PC on the same network (with a similar USB ethernet adapter) I ran some iperf3 performance tests (half expecting to see flakey results)

Obviously the choice of buffer length will be significant due to overheads of smaller packets, but I was just keen to see if there was any difference between send/receive and or obvious issues with the adapters, particularly for upload.

iperf3.17_64>iperf3 -c 192.168.0.2  -p 5201 -t 10 --length 10000
Connecting to host 192.168.0.2, port 5201
[  5] local 192.168.0.4 port 65383 connected to 192.168.0.2 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec   258 MBytes  2.16 Gbits/sec
[  5]   1.00-2.00   sec   266 MBytes  2.23 Gbits/sec
[  5]   2.00-3.00   sec   246 MBytes  2.06 Gbits/sec
[  5]   3.00-4.00   sec   254 MBytes  2.13 Gbits/sec
[  5]   4.00-5.00   sec   248 MBytes  2.08 Gbits/sec
[  5]   5.00-6.00   sec   260 MBytes  2.18 Gbits/sec
[  5]   6.00-7.00   sec   263 MBytes  2.21 Gbits/sec
[  5]   7.00-8.00   sec   237 MBytes  1.99 Gbits/sec
[  5]   8.00-9.00   sec   253 MBytes  2.12 Gbits/sec
[  5]   9.00-10.00  sec   253 MBytes  2.12 Gbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec  2.48 GBytes  2.13 Gbits/sec                  sender
[  5]   0.00-10.02  sec  2.48 GBytes  2.12 Gbits/sec                  receiver

iperf Done.

For the record I am using the inexpensive NWC330GCA adapters from Wavlink to provide 2.5G links.
Be aware there has been a relatively recent update to the RTL8156B driver on Windows.
I’d recommend updating if you have similar.

I’m currently using:
RealTekDriverVersion

Very good info! Was this direct connection or via a switch/router

1 Like

@WhyAydan Connection for the specific LAN test was via D-Link DMS-107 switch (which has 2x 2.5G ports and 5x 1G ports). The Yayzi EX820v router was plugged in via 1G port (just to provide DHCP).
I was really just try to see if there was a problem with the RealTek chipset performance on my 2.5G network.
Just FYI, reconfigured the network to use the 2.5G port and this morning on the WAN I’m getting 1.6Gbit/s down & 774Mbit/sec up but I was expecting symmetrical performance like my previous provider.
I’m probably better off switching to a 1Gig service which is a lot cheaper and I have many competative ISPs offering that.

The big problem here from my experience is that RealTek NIC’s are just a bit shit.

Ive had issues with them on and off for years and since switching to Intel NIC’s ive had no issues at all.

I cant help with your issue other than to suggest getting an Intel 225 2.5Gbe NIC

The point of my LAN test was there was no problem with the adapter - it was happily sending/receiving and met my expectation.

I agree the Intel would be better, but it doesn’t explain why my upload speed on the WAN via the EX820v is so poor. I’m meant to be on a 2Gig Pro+ with a speed guarentee (that isn’t being met)

We’re seeing the speeds to your router without issue, so I don’t believe the issue is on our end, but we will try our best to assist you with this and I’m sure everyone in the forum will offer advice too :slight_smile:

Screenshot 2024-06-26 at 14.18.05

2 Likes

Have you tried bypassing the Yayzi router? Just curious :slight_smile:

vLAN 911 I think

I use several USB-C Realtek 2.5Gbe adapters on my computers at home here, and haven’t a single issue with any of them. This is a test just now on my work laptop using a Wavlink WL-UHP3414 dock with RTL8156:

Same results from an Anker USB-C 2.5Gbe adapter running on a mini PC, and from a built-in 2.5Gbe port on my MSI m/b.

EDIT: I’m on the 2Gig Pro+ service, so these are exactly the expected speeds.

2 Likes

Yes, fortunately the adapter has VLAN support so I was able to configure 911 & I did try a test briefly using an old ThinkPad.
I didn’t really want to expose the box directly to the Internet for too long.
Sure enough within a few minutes MalwareBytes was popping up alerts from port probing so I abandoned the test.
I managed a speedtest but I think the limiting factor was the laptop as it is severly cpu compromised by today’s standards.

Interestingly there we no drops but speed wasn’t as good as the RPi 5 while using the router.

I gave up trying to get the right permutation of parameters with ethtool on the PI to enable the adapter to use the VLAN 911 and talk direct to the WAN.

In contrast, on Windows the Realtek Ethernet Diagnostic Utility is really simple to use for defining VLANs and testing cables.

The Yayzi_Team are confident the connection is ok so they conclude the problem is at my end.
They added that because I was GPON and not XGS-PON I won’t be able to exceed 1Gb up.

I will talk to them about downgrading my service to the 1Gb up/down.

1 Like

Hi Icarus,

The 2gb Pro package is not symmetrical. You’d be looking at the 2.3Gb Pro package for symmetrical 2Gb + speeds. I think this is dependant on the network in your area being capable as well.

Cheers.

Yes I realise that now being stuck in a GPON area. Yayzi have kindly switched my package to the 1.2Gig Pro+ as I can’t really exploit the faster speeds at the moment.

1 Like

Thats good news! Didn’t it say this when you ordered it mind you?

My fault really. I querried with Customer Support as to whether I was in a GPON or XGS-PON area and Chris confirmed the former. They said:

We can supply the 2GB service to you

I didn’t appreciate that it meant no more than 1Gbps upload until I’m converted to XGS-PON. At least my ONT has been upgraded to the 2.5G version and hopefully in future I won’t need another engineer visit.

I must say the folks at Yayzi have been very accomodating and I’m happy to stay with them.

1 Like

No idea why they aren’t doing new installs with XGS.

1 Like

All areas are technically XGS-PON ready, just got to be turned on. So far the date for that is around August this year, but that could obviously change.

We will post more accurate updates once we have them :slightly_smiling_face:

2 Likes

You’ll need another engineer to upgrade your ONT again when XGS-PON goes live (You’ll get a 10GB ONT)

1 Like

Don’t laugh: they sent an engineer to change my ONT when they downgraded my 2Gig Pro service to 1Gig Pro (Regrade). I kid you not.

1 Like

Yeah this should not have happened at all, CityFibre systems still don’t seem to be able to cope with MultiGig changes -_-

1 Like

Any updates on the new portal? Would love to beta test it