XBox NAT Type - No Teredo IP

Interesting one.

Resurrected the Xbox One as my son wanted to do something online with it. No dice. Couldn’t detect the NAT type due to being ‘unable to get a Teredo IP address’. Very strange. Haven’t used the console for a long time so last time was when we were with VM - no issues then and got open/moderate NAT no problem. Reverted back to the exact same setup I had back then with the Opnsense gateway with UPNP enabled for that particular IP - still no joy.

Bit of Googling and it turned out some people had the same issue and it was down to an issue with the ISP. So, just reaching out to @Yayzi_Team to check if there is any reason this may be happening now?

I know others on here are Xbox gamers so assume you don’t have the same issue? The issue certain users had with VM was location specific so it may well be OK for you guys but not for me, unless you’re in the same area as me - East Suffolk.

Cheers.
Keeop

I’ve come across NAT D before not sure if it’s the same, check the ports you need open on your firewall for the connection to be successful.
Have a Google you should be able to find out if you don’t know already.

But the point is I have UPNP enabled for that device so open ports/firewall/forwarding is not the issue here.

Ok so what else haven’t you said above that will help to diagnose the issue? :slight_smile:

Ha! Yeah, I didn’t want to go in to all the details of my setup as it had been working perfectly when using VM. So, my query was more aimed at Yayzi in case there was an issue with them. As I said, some VM customers suffered from the same problem and it was down to a localised VM issue.

One of the main reasons I moved across to Opnsense was for the sheer amount of stuff it could do, one of which being targeting specific devices to be able to take advantage of UPNP - absolutely essential for some bloody Nintendo titles whose only other advice is to forward every port to your console!! So yeah, UPNP enabled on Opnsense for my consoles.

I have mainly been using the UDM SE recently though so was attempting to test out their UPNP feature. Was getting the ‘Teredo’ error so flipped back to what I knew worked - Opnsense - but still the same problem persisted. On Googling, a lot of the comments said to check with your ISP. Some people had the problem, changed ISPs and were then working. Others flagged it with their ISP and got it resolved. As I said, some VM customers had the issue in a particular area which VM did recognise as being an issue with them, Hence, this is more aimed at Yayzi really but am also curious as to whether anyone else is having success or failure with this in my East Suffolk area.

Cheers.
Keeop

Just as a side, you are aware that Upnp is a security risk ?

I think that some providers block ports or put traffic management in place which Yayzi don’t do I don’t believe.

I use a UDM-SE as well, but don’t use an Xbox, as the students do, we just have to work out why they don’t work

Goggling teredo errors the error is a translation between protocols ipv4 and IPV6 are you using, ipv4 addresses internally and IPV6 through the internet?

Teredo is short for Teredo tunneling, in this context. Think of Teredo as a translator between different versions of the Internet Protocol (IP), specifically version 4 (IPv4) to version 6 (IPv6.) The entire internet is slowly upgrading to version 6 over time, but that leaves many people using the outdated protocol. Teredo tunneling is used in situations where one endpoint of the tunnel is private, such as behind a router. That way, it can translate smoothly between the two protocols, allowing them to share data.

Indeed I am which is why it is only enabled for console devices on my network.

Yep, know about Teredo tunneling as it s also used by MS Direct Access.

I am only using IP4 and will continue to until Yayzi roll out IP6.

The overall point here though is that this all worked when I was on VM. However, this was a good several months ago so it is also possible that MS have changed something but the overall consensus is, that if it is not yourself blocking anything, then chances are it is issue with ISP. As I said, some people who had issues changed ISP and all was resolved.

Cheers.
Keeop

That’s right Toredo is a technology so it’s used by many layer 3 applications :slightly_smiling_face:

Like I say I don’t think they do any blocking,
@Yayzi_Team . is there not an app on a laptop that you can test for the ports and connectivity?