Xbox disconnections

Okay so since I have had Yayzi installed my son has been getting loads of disconnections on Fifa 23 on Xbox series X I have tried wired and wireless and both do it. I have one unhappy son and even virgin was a solid connection compared to this.

You’re the second person to flag similar in two days, I haven’t played FIFA in years, but EA’s servers were never the best, that said the other issue was Fortnite. Can I suggest testing other (non EA) games and seeing if they exhibit the same issue? It’s just it gives an indication as to if this is a peering/routing to EA’s server issue or a wider issue.

@Keeop was the other person struggling here

As @Avalon said above, if you can do that for me we can look into this

Yes I will ask my son to test tonight some non EA games. Thanks

@Keeop did yours sort itself out or are you still having problems

@supershaun Has been an issue since the connection has been used for gaming. I have asked the kids to report back on any other games that have issues but not sure if they’re playing any other esports type titles at the moment, where lag is more frustrating. Will find out later when they’re allowed on! However, unless anything has been detected Yayzi’s end, I imagine it will still be an issue.

Cheers.
Keeop

Okay thanks for getting back to me I have asked my son to try a couple of games later on also. It’s so frustrating as virgin media was rubbish but never had this issue whilst using them. I know it will get sorted eventually :+1:

Yep, still pretty bad - actually not being able to move bad. I might well have to cancel my VM cancellation as we can’t carry on like this.

Oh no this is not good. I will use to keep an eye on it as my son will go into melt down if he can’t play. Thankfully there is a 14 day cooling off

Are you wired or wireless?

Are you using DHCP IP addresses or statics? What DNS do you use, these all come into play (or not)
If you’re using a DHCP address try a static IP address.

Static. Same DNS for both Yayzi and VM. Fine with VM, laggy with Yayzi. Speeds in general look a bit iffy tonight though:

Any more information around this would be helpful, wired or wireless when gaming, if you have any other consoles or PC gaming are they having similar issues.

We can always add more peering to resolve this issue, but if this wasn’t an issue previously then it should be now.

We’ve added more transit providers and more peering and the only other thing really changed is we’ve got rid of CGNAT

Try changing the DNS to see if it makes any difference

As much as that definitely does seem iffy. Latency is king for gaming, don’t really need much speed for the actual gaming experience.

Really keen to get this resolved though, I’m a gamer myself so I know how important this is

Have had both kids playing (at different times) and I have also played a few games on my own PC (badly of course!) so I can see it all myself. Same symptoms on all the machines. They’re all wired, mixture of 2.5Gb and 1Gb to the core switch, 10Gb from core switch to either the UDM or Opnsense box - whichever one I go with I get the same lag/in-game packet loss/disconnections which I don’t get when I unplug the cable from the router to the ONT and whack it back in the VM modem.

Doing this, I can see first-hand the in-game lag when connected via the ONT to Yayzi which is non-existent when I plug the VM modem in instead and continue. It is a bit nuts as the latency with Yayzi is much better than VM. The only time I’ve seen the VM connection behave similarly is when there is a noticeable problem on the line and there is visible ICMP packet loss. With the Yayzi connection, ICMP pings seem fine - a bit of variance but not much - whereas the game will throw up it’s ‘connection lost’, ‘packet loss’ messages along with visible non-movement lag etc.

I can’t say for sure whether this is since being put on the 185. network as I have only fully switched the house over in the last few days. I did flip them over for a day several weeks ago just to pick up any obvious issues, but I didn’t get any reports of laggy play at that time. I was on a different address range then as it was before the ‘issues’!

Trouble is, they seem to only play online games in phases and at the moment it’s just Fortnite so I can’t comment on any other issues with other games or not. Me, I’m just happy with a bit of slow Civ…!

Cheers.
Keeop

Agreed, just thought it might be related to something else going on.

I’m getting similar issues spanning from packet loss to disconnects on Xbox. It’s intermittent and obviously hard to know for sure whether it’s the connection or individual games, but it’s been happening across a few games now while mates have remained in the same games without issue.

Also not sure if related but I seem to see big spikes in packet loss on the ThinkBroadband quality monitor when downloading things on Xbox too, seems excessive given this download was only going around 400mbps on a 2.5gb line, would have thought the router could handle the ICMP traffic at the same time.
IMG_9550

Edit: I’m on a 141. IP so not sure it’s specific just to 185.

I’m on the 185 Ip range and have no issues gaming, albeit I only really play a couple of games. I have not tried xbox but my daughter hasn’t complained and she’s on PS5. I know it doesn’t help you other than to suggest it’s not a Yayzi wide, or Ip range issue. However it could be an issue with certain games on xbox.

Well, it’s repeatable and has been the same this evening. Yayzi - in-game issues. Flip over to VM - where the only difference between client and server is the broadband connection - no issues. To re-iterate: this is going out via the same gateway; using same DNS etc., etc. The only differing factor is the broadband connection. But yeah, same again this evening. Only real difference today was I did notice some corresponding larger ICMP times but these were not exactly large, just larger than the norm by around 2 or 3 times. Still lower than normal VM latency but no in-game issues on VM.

Cheers.
Keeop

It does seem a strange problem.