Unable to access https://onedrive.live.com/

I am unable to access https://onedrive.live.com/ from any of the devices on my network, page loads with “The request is blocked.”
Site is working fine over if I connect to a VPN or use 4g on my phone but as soon as I come from my Yayzi IP it redirects me to OneDrive
With the message “The request is blocked.”

Are you on a 149.x.x.x Wan ip?
Maybe a geo ip issue (USA) or the IP address is flagged as suspicious/banned on a spam database.

check https://www.ip2location.com/demo

there is a ongoing thread about Geo IP and sites not working.

https://talk.yayzi.co.uk/t/ip-geolocation-issues-please-read/1293

I’m on the 141.x.x.x range it is showing as in the UK on the database. I have looked online and can’t see a way to check if Microsoft have blacklisted me, seems strange that it only happens when attempting to access the OneDrive website. I am unable to find any other Microsoft services that are blocking me.

1 Like

@muz I have just tried the website for you and I’m also on the 141 ip and also. It’s blocked for me also so must be a Yayzi ip problem.

I’m glad it’s not just me going mad over here. Thanks for checking, @Yayzi_Team can you look into this?

1 Like

Looking into it guys! :slight_smile:

Chuck the IP in here and see if its blacklisted anywhere

It is only flagged as a residential IP and that’s normal. I spoke with Microsoft but it seems to only be affecting personal OneDrive and not business/Sharepoint url so business team couldn’t assist, would have to be logged as a personal OneDrive. I don’t like my chances of getting through to the free support and them understanding the issue. Hopefully Yayzi can work out why we have been blocked and sort it.

Good luck with the level 1s techs on the personal side lol

1 Like

Ticket is logged, I don’t expect to ever see a response. Had to use a VPN to load the support page :rofl:

Also seeing it on 141.
Post last week from an ISP/MSP seeing the same thing with the same Ref B coming from a London DC. Agree its most likely the whole 141.11.200.0/23 is getting flagged (Unless someone else 141 can confirm otherwise)
Even Microsoft premier support on the business side is utter tosh so wouldn’t hold out for a quick resolution.

Side note, tested the OneDrive desktop client and it still connects if you need access to files in the interim.

1 Like

Yes same for me the app works fine only the website with issues. I did manage to get a call from someone on the Sharepoint team but as the business side of the app was working the best he could do was provide a link to the personal support page.

Here is the reply from Microsoft.

“We reviewed your response with concerned team. We would like to inform you that as OneDrive web is working with another network and using VPN, however, issue persists on home network only. In this case, it is related to your ISP as it may be blocked from their end. Your account and services are active from our end. In this case, we would suggest you to contact your ISP so they can assist you. We wish we could help more in this case but this is out of our support boundaries.”

Guess it’s now over to @Yayzi_Team to find the issue or have better luck talking with Microsoft.

1 Like

Ive checked on Mx toolbox and for me nothing is blacklisted it says but still have the same issues

149.18.86.xx
National lottery - stopping me winning my millions… Or not ha!

1 Like

What is bizarre is certain services are working fine, so are they using different providers for different services (geo providers)

It doesn’t make any sense at all. We’ve reached out to them directly to clarify

1 Like

Microsoft do like to fob off the customers though

Microsoft are a nightmare, and based on past experience simply wont solve it. Trying to get past their front line support and to someone that isn’t reading off a script is impossible.

I tried for a couple of month to get them to tell me what geo database they use and what my IP address (also a 141.11.200.x address) was showing, as I couldn’t access the Xbox Rewards thing. It just won’t load at all for me, but then if I turn wifi off on my phone it works fine. Raised with multiple teams, nothing ever got done. Haven’t bothered Yayzi about it though as it’s ultimately a tiny issue and I figured hopefully when we move to IPv6 these geolocation issues will go away.

I’ve emailed national lottery to see if that helps